IPTV Data Server – No EPG Problem

About Forums Support IPTV Data Server – No EPG Problem

This topic contains 11 replies, has 4 voices, and was last updated by  dcol 1 month ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #41057

    restalfep
    Participant

    When I use my PC as the IPTV Data Server, it shows the EPG on the PC with no problems, and shows it linked to the correct channels but when I use my FireTV, Shield, AndroidTV, etc they only pull the Playlist from the IPTV Data Server but never the EPG it seems. All of them show Playlist downloaded (XXXX Amount) but EPG either doesn’t show as downloaded at all on the top right or on one of the devices it just shows EPG Downloaded but no number, so it doesn’t actually download anything.

    Is there a setting or something I’m missing here? I tried many different options and restarting, etc but nothing worked. I turned off the firewall also but made no difference.

    I organized my channels and groups on my PC so I really don’t want to have to reset and lose all my setup. Any ideas what is going on here?

    #41058

    restalfep
    Participant

    So after further testing it seems it’s because the IPTV provider gives their EPG as link ie. http://iptvlink:88/xmltv.php?username=XXX&password=YYYY but even though Perfect Player on PC can read this, and the client could if not using Data Server but instead using direct URL for Playlist & EPG, it can’t use that data when it’s getting passed from Data Server to PP Clients. How can this be fixed?

    #41059

    King200
    Participant

    Settings->General>EPG1= (USA)
    https://raw.githubusercontent.com/acidjesuz/EPG/master/guide.xml
    https://raw.githubusercontent.com/kens13/EPG/master/guide_ks.xml
    —————————————————————————
    Settings for Playlist have the Username/Code in XC settings.

    What happens when you go to Defaults->Save Settings>2019020323_PCA.ppbck. Use that file to import settings to your Android device.

    #41060

    restalfep
    Participant

    I’m a little confused by your post, unless I’m missing something. I already have those EPGs but they aren’t linked to any of my channels and automapping doesn’t work for them.

    If I go to General Settings and enter a Playlist and EPG manually from my provider then that always works but I’m trying to do this via IPTV Data Server option instead, which is the top option under General > Settings.

    My provider gives me an EPG via their link .xmltv.php?username etc as shown above which matches perfectly to my channels since the m3u and EPG is from them. However this doesn’t work when using IPTV Data Server. The EPG links you listed do show, however almost none of them auto match properly at all (33 out of hundreds).

    The strange thing is on the PC itself with Perfect Player (acting as the IPTV Data Server for Perfect Player), the providers xmltv.php?username link works correctly on the PC itself when watching or looking at EPG, but none of the Perfect Player clients that connect to that PC will get the EPG correctly.

    I don’t want to use the EPG under each clients’ Perfect Player General > Settings since that won’t work with IPTV Data Server. I’m using a Data Server since it is much easier to configure everything how I like on the PC than trying to do it with a small remote manually.

    #41061

    restalfep
    Participant

    In regards to my last post, I should say “and automapping barely works for them (33 out of hundreds” instead of doesn’t work.

    #41064

    nikman
    Keymaster

    Could you try it with another EPG source? Just test if EPG will show on couple of channels.

    #41069

    restalfep
    Participant

    The main EPG (http://iptvlink:88/xmltv.php?username=XXX&password=YYYY) is the one that has the issue, but that is the most important since it automaps the majority of the channels properly.

    So that main EPG will work on the PC itself, and also on the FireTV and ShieldTV if I enter it as the EPG directly on there, but then I have to use a playlist on each one and I lose all my IPTV Data Server settings that I customized from my PC.

    When using as the PC as the IPTV Data Server, then the main EPG will not send to the FireTV or ShieldTV. But if I use a different source like: https://raw.githubusercontent.com/acidjesuz/EPG/master/guide.xml then it will send properly but then only 33 channels are mapped and the hundreds of other channels would need to be manually mapped 1 by 1, which would take forever.

    I’m assuming that the IPTV Data Server is having an issue since the link is http://iptvlink:88/xmltv.php?username=XXX&password=YYYY and not .xml directly but I don’t understand why it works fine on the PC itself and directly on the FireTV and ShiledTV but not when using the IPTV Data Server option instead. Without being able to fix this, it means IPTV Data Server would be useless and all the customizations are wasted time so I really want to figure out how to use that main source properly when using IPTV Data Server.

    #41070

    restalfep
    Participant

    In addition to my last post, is there a faster way to set EPG & Logos to Channels, when I do it one by one, it makes it so I have to click the EPG item, hit Set, then it reloads everything which takes 10-20 seconds, then I have to go to logo hit set, then it reloads everything again which takes 10-20 seconds. I would have to do this 1 by 1. Is there any way to set more than one at a time, or not have it reload everything every time I hit set for one EPG or one logo?

    #41071

    nikman
    Keymaster

    You can use Auto update checkbox in the EPG matching buttons section.

    #41078

    restalfep
    Participant

    Tried that but on PC it won’t auto match the majority of the EPG, unless I use the main EPG (http://iptvlink:88/xmltv.php?username=XXX&password=YYYY), but then when the PC is IPTV Data Server using that, the clients that connect to it get no EPG.

    #41317

    dcol
    Participant

    I have same issue. I have three IPTV m3u’s and three xml’s all work fine on the Android TV. I just added another one and the EPG does not show up on Android, but is ok on the PC. I am going to try using xTeVe and see if that helps

    #41318

    dcol
    Participant

    Using Xteve worked

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.